Home/Support/Support Forum/Can't connect remotely to the Digi One SP
Welcome to Digi Forum, where you can ask questions and receive answers from other members of the community.

Can't connect remotely to the Digi One SP

0 votes
I can't connect to the Digi One SP from a distant location. At home I have no problem connecting to the Digi One SP.

My serial device provides outgoing signals to the Digi One SP, which is then connected to my router. I enter the remote IP address and port # for the TCP client on the application software that I'm utilizing at home. Once I connect with the application on my computer it connects without any problem.

The problem arises when I connect from a distant location utilzing the same application software.

Does anyone have any input for a possible solution? Thank you in advance.

John
asked Nov 26, 2006 in Portserver TS by watermon New to the Community (7 points)

Please log in or register to answer this question.

6 Answers

0 votes
You will want to confirm there is no firewall blocking access to the unit.

Try checking to see if you can connect to the unit using telnet or ssh.
answered Nov 27, 2006 by userid0 Veteran of the Digi Community (2,158 points)
0 votes
It's most likely a Gateway/router issue.

When your PC host "connects" the DOSP, the DOSP has 2 methods it can use to select how to establish the reverse TCP socket.

Loacl) If the subnet mask (the 255.255.255.0 as example) indicates that both PC and DOSP are on the same network, then the gateway setting is ignored and the DOSP broadcasts an ARP to find the PC to complete the TCP socket open.

When you are accessing the DOSP remote via Internet or routers, the the DOSP will detect the IP mis-match and need to ASK the local router (as "Gateway IP") to act as proxy to enable the return TCP socket to be built.
answered Nov 27, 2006 by lynnl Veteran of the Digi Community (1,047 points)
0 votes
Thanks in advance for your assistance.

At my computer which is connected to the same router as my Digi One SP I have no problem with a connection.

When I go down the street to a friend's house, I can't access The Dig One SP . In the application software I'm using for the outgoing data feed I enter the Digi One SP ip address and port number. Yet I can't connect

I'm trying to follow the content in the link you provided http://ftp.digi.com/support/techsupport/hardware/portserver/rtelnet.html
Yet I'm stuck on the third step.

I see that I just randomly pick a port number and add it Telnet TCP Port: 2001

I'm sure the problem is in my router configuration and I'll just have to figure it out somehow

Regards,

John
answered Nov 28, 2006 by watermon New to the Community (7 points)
0 votes
DOSP = Digi One SP... I got it now. Please Ignore my earlier reply asking the dumb question what the acronym DOSP means.

I'm trying to decipher what you are patiently explaining but I still don't quite get it.

I'm at a friend's house trying to populate the control panel for my DOSP. Its the Digi One SP Configuration and Management web page where I can configure all my setting for the DOSP

I can't access it at all. Just like I can't access the data feed from the DOSP. The Gateway LAN is the same IP address as my D-Link Router.

I believe the problem lies in the router and I need to configure it properly. I think I'll unplug the DOSP from the router and plug it directly into the cable modem... no firewall there, right?

Then I'll call up my neighbor and ask him if he can access the DOSP w/o the router connection. I believe this will be a reverse telnet connection, right?

Thanks for your assistance,

John
answered Nov 28, 2006 by watermon New to the Community (7 points)
0 votes
Ah, I see - if you want

[PC] -> [Router#1] -> Internet -> [Router#2] -> DOSP

Then you'll need to set:

1) in DOSP, make sure Gateway is Router#2 - nothing related to Router #1 or PC. Technically, when packets arrive at DOSP, it will LOOK LIKE Router #1 is talking! (This is part of NAT function). So even if your PC has IP 192.168.1.20 and DOSP has IP 192.168.1.50, it will not be 192.168.1.20 talking to DOSP, but your ISP's IP such as 66.23.75.128.

2) In router #2, you'll need to set up the IP forwarding (also called Port Forwarding or Applications/Games). If the DOSP has the IP 192.168.1.50, then you should forward TCP ports 80 (web), 771 (RealPort) and 2101 (TCP Sockets) to that IP.

3) Of course in the remote PC you need to point your tools at the ISP's IP for Router #2. So PC think it is talking to Router #2 and DOSP thinks it is talking to ROuter #1 - strange world of NAT :-)

4) if your Routers have dynamic IP (most likely do), take a look at www.dyndns.org to set up a free DNS name for yourself
answered Nov 28, 2006 by lynnl Veteran of the Digi Community (1,047 points)
0 votes
Maybe, it's permission level issue. You need to consult it with Toshiba Customer Care: http://supportnumbers.net/toshiba-support/
answered Jun 29, 2017 by toshibasupport New to the Community (1 point)
Microsoft Outlook Support endows the solutions to the users for their outlook account setup on their devices such as laptop/pc/mobile, and tablets for all platforms like windows, apple, android. https://microsoftsupports.net/microsoft-outlook-support/
...