Home/Support/Support Forum/SPI clock mode will not change - RCM3750
Welcome to Digi Forum, where you can ask questions and receive answers from other members of the community.

SPI clock mode will not change - RCM3750

0 votes
I have used SPI many times with RCM devices and now have a need to use SPI with a new device that uses a different clock edge and bit pattern than default --- every effort to change clock mode using the SPI library and SPI_CLOCK_MODE has failed --- even writing to SBER register direct fails and changing to user mode in SBUER fails --- I am currently using an RCM3750 --- please help me change the clock mode on my device for this application
asked Jul 6, 2014 in Rabbit Software by bhuelster New to the Community (1 point)

Please log in or register to answer this question.

2 Answers

0 votes
Hello,

I recommend using DC9.62 and make sure you have all the latest patches. This is available on the www.digi.com website under documentation.

This should be as simple as adding

#define SPI_CLOCK_MODE 0,1,2, or 3

to the top of your code

If this doesn't work try adding it to the DEFINES window of project options.
answered Jul 7, 2014 by trooper2 Veteran of the Digi Community (589 points)
0 votes
Thank you, I have DC9.62 and have already tried the #define SPI_CLOCK_MODE --- to no avail ---- however, I have not installed any patches and will look into that
answered Jul 8, 2014 by bhuelster New to the Community (1 point)
...