Home/Support/Support Forum/BL4S100 waiting target response timeout
Welcome to Digi Forum, where you can ask questions and receive answers from other members of the community.

BL4S100 waiting target response timeout

0 votes
I compile the source file like DEMO1.c on dynamic 10.70 with USB programming cable connected with BL4S100, but there are some errors like BL4S100 waiting target response timeout. I don't know what's wrong? It's my first time to use BL4S100. My computer is Win 7. I need help. Thanks.
asked Sep 15, 2014 in Rabbit Software by wgx247 New to the Community (1 point)

Please log in or register to answer this question.

5 Answers

0 votes
When you installed Dynamic C, did you have your board powered up and connected via the programming cable?

If not, uninstall and reinstall Dynamic C with board powered up and attached to the PC via the cable.

If this doesn't take care of the problem, try going to Device Manager, in the USB COM port’s “Advanced Settings” dialog box there is a “Latency Timer (msec)” selection drop-list. It was found that reducing the latency setting from the (apparent) default of 16 msec to a much smaller value (1 or 2 or 3 msec) resulted in much better performance and problems with frequent target communication errors. Experiment a little and use the highest latency setting that doesn’t cause frequent TC errors.
answered Sep 15, 2014 by trooper2 Veteran of the Digi Community (589 points)
Thank you very much. Finally, I resolve the problem as you said.  Now it can be compiled....
0 votes
I also suggest that you download our current release of Dynamic C 10.72
answered Sep 15, 2014 by MargaretK Veteran of the Digi Community (545 points)
Thanks very   much ...
0 votes
it is because the rate is too big, you need to change it. Options>Project Options and choose a lower Max download baud rate, and the most probably is that you need to change too the default degugging rate to the lower lever.
answered Sep 24, 2014 by lorduque New to the Community (1 point)
0 votes
Sometimes lowering the baud rate could make things worse. This time it seems to have been the latency timer.
answered Sep 25, 2014 by MargaretK Veteran of the Digi Community (545 points)
0 votes
Hi, guys, Thank you for your help, Lowing the baud rate is Ok and I think the both baud rates should be same. I have a new question Do you know why this sentence
printf ("\x1B=%c%c%s", 8, 5, " <<< Digital inputs 00 - 11 >>>") will show the string at (8,5) at the dynamic C stuio window. I know \x1B is 27 in decimal which is ESC. but I don't why this sentence makes this result. Thanks..
answered Sep 26, 2014 by wgx247 New to the Community (1 point)
...