Home/Support/Support Forum/Port server ts 4 faxing problem
Welcome to Digi Forum, where you can ask questions and receive answers from other members of the community.

Port server ts 4 faxing problem

0 votes
I am trying to setup a faxing on port server ts 4 , with latest firmware, multimodem mz5656, and using the adapter i made from the port server modem adapter specs. for some reason fax fails during transmission. I am using linux centos 5 and hylafax. I f i use the same system with etherlite and etherlite modem adapter it works. but with port servers i couldnt able to make it work. I checked the modem log and it shows this.

Oct 15 15:52:44.41: [21538]: <-- data [641]
Oct 15 15:52:46.69: [21538]: <-- data [2]
Oct 15 15:52:46.69: [21538]: --> [2:OK]
Oct 15 15:52:46.69: [21538]: <-- [9:AT+FTS=7\r]
Oct 15 15:52:46.69: [21538]: --> [9:MT5656ZDX]
Oct 15 15:52:46.69: [21538]: --> [5:ERROR]
Oct 15 15:52:46.69: [21538]: MODEM Command error
Oct 15 15:52:46.69: [21538]: Stop and wait failure (modem on hook) {E127}
Oct 15 15:52:46.69: [21538]: SEND end page
Oct 15 15:52:46.69: [21538]: SEND: Stop and wait failure (modem on hook) {E127}; Giving up after 3 attempts to send same page "docq/doc7.pdf;1d80", dirnum 0
Oct 15 15:52:46.69: [21538]: <-- [9:AT+FRS=7\r]
Oct 15 15:52:46.69: [21538]: --> [8:<8a>OÃ<8a><8a>OÃ<8a>]
Oct 15 15:52:46.69: [21538]: --> [2:OK]
Oct 15 15:52:46.69: [21538]: <-- [9:AT+FTH=3\r]
Oct 15 15:52:46.69: [21538]: --> [2:OK]
Oct 15 15:52:46.69: [21538]: MODEM input buffering enabled
Oct 15 15:52:47.69: [21538]: <-- [5:ATH0\r]
Oct 15 15:52:47.79: [21538]: --> [2:OK]
Oct 15 15:52:47.79: [21538]: MODEM set DTR OFF
Oct 15 15:52:47.82: [21538]: STATE CHANGE: SENDING -> MODEMWAIT (timeout 5)

it fails at this point where it says [8:<8a>OÃ<8a><8a>OÃ<8a>]

anyone knows why?
Thanks
asked Oct 16, 2015 in Realport by keskin New to the Community (0 points)

Please log in or register to answer this question.

1 Answer

0 votes
If you connect directly to the tty port using cu, minicom, etc...and issue those AT commands are you successful or do you see errors.

Based on the garbage characters seen, you might need to train the modem speed:

If the Modem has DIP switches, set them to the async default position.

The command sequence for the modem should be:

at&w1z -- reset modem to factory defaults
and read DIP switches if present

at$sbs0=1&w -- locks DTE speed at port speed
and stores to NVRAM

If you are using 8 wire cabling, make sure the altpin setting is applied to the port on the PortServer unit.
answered Oct 19, 2015 by userid0 Veteran of the Digi Community (2,158 points)
...