Home/Support/Support Forum/RCM6750 Backup battery drain
Welcome to Digi Forum, where you can ask questions and receive answers from other members of the community.

RCM6750 Backup battery drain

0 votes
Hello,

I know this topic has been covered before but here's another twist to the story: When powered down the current draw on the battery is about 42uA - which closely matches the 50uA specified in the documentation. However, when power is applied the draw goes up to 5mA draining the battery in a matter of a few days.
I went through all the procedures found on related bulletin boards or FAQs to lower the current draw and tried brand new RCMs to no avail.
As expected, the current draw from the battery is 0A without the controller installed.

Thanks for any hints or ideas!
Martin
asked Jun 22, 2016 in Rabbit by mfuhrer New to the Community (4 points)

Please log in or register to answer this question.

2 Answers

0 votes
Can you provide details on how you've interfaced the RCM6750 to your carrier board? If you connect a battery to the VBAT pin of an RCM6700 Minicore Development board, do you see a similar draw?
answered Jul 13, 2016 by TomCollins Veteran of the Digi Community (1,457 points)
Thanks for the idea Tom! I'll give it a try and will let you know the result.
0 votes
Hello Martin,

Two suggestions.

The first version of the 6000 processor had a much higher current draw. Check to see if the processor version is A or B.

Second, this might be a sequencing issue between applying the battery and the power connector. The RCM6700 user manual in "Appendix G: Power Supply" covers the sequencing of how the battery and mains power should be applied.
answered Jul 20, 2016 by trooper2 Veteran of the Digi Community (589 points)
One more suggestion.  Please check that the power supply voltage has not dropped. This can cause significant drain on the battery if the power supply voltage is not maintained.
...