Home/Support/Support Forum/xlr pro ethernet setup

xlr pro ethernet setup

0 votes
We purchased a pair of XLR PRO radios and I am looking for information on how to set them up to communicate through the Ethernet ports. There is plenty of info on how to setup for serial comms but not so much for UDP or TCP.

Here is what I'm doing. For initial testing I am hooking each up to a laptop and using a crossover cat6 cable to connect to the laptop. I was planning on using Putty to test communications. Basically, as illustrated below.

Laptop1<--crossover cable-->Radio1 )))data))) Radio2<--crossover cable--> Laptop2

Radio1 is setup as follows:
ES (IP socket mode enabled): enabled
IB (IP mode baud rate): 70800
IP (IP socket protocol): TCP
DX (destination IP addr): 192.168.4.56
CO (source port): 2616
DY (destination port): 2616
MA (IP addressing mode): static
MY (IP address): 192.168.4.55
MK (Subnet mask): 255.255.255.0
GW (Gateway addr): 192.168.4.1
NS (DNS address): 0.0.0.0

Radio2 is setup as follows:
ES (IP socket mode enabled): enabled
IB (IP mode baud rate): 70800
IP (IP socket protocol): TCP
DX (destination IP addr): 192.168.4.55
CO (source port): 2616
DY (destination port): 2616
MA (IP addressing mode): static
MY (IP address): 192.168.4.56
MK (Subnet mask): 255.255.255.0
GW (Gateway addr): 192.168.4.1
NS (DNS address): 0.0.0.0

I tried to use putty with the settings as follows:
IP address: 192.168.4.55 (for Radio1 ... 192.168.4.56 for Radio2)
port: 2616
connection type: telnet

putty is not able to connect on either computer.

Please let me know what I am doing wrong here ... it seems simple but I am obviously messing up something. The final operation of this will have one end will have a single board computer talking to Radio1 through a switch and Radio2 will still be connected directly to a laptop using the crossover cable.

Thanks, in advance, for your assistance on this.
asked Jul 27, 2017 in XLR PRO by vbplaya New to the Community (0 points)

Please log in or register to answer this question.

1 Answer

0 votes
From what I see, it looks like you are missing the BA command for each unit. Set it to the MAC address of the other unit.

Also set BE to 1
answered Jul 27, 2017 by mvut Veteran of the Digi Community (11,302 points)
...