Home/Support/Support Forum/Firmware upgrade for Connect ME 9210 fails
Welcome to Digi Forum, where you can ask questions and receive answers from other members of the community.

Firmware upgrade for Connect ME 9210 fails

0 votes
Hello,

several times now, when trying to upgrade the firmware the
ME 9210 module has died, i cant't find the IP, the LED is constantly green.
(The Net-OS is up to date. I must recover the digi with shorting the pin...)
Befor the upgrade, i uploaded the backup.bin (the memory mapping have space for the backup.bin).
In the backup.bin is a different version number and i have never seen this number after the update.

This problem exist also for years, but with a update from the Net-OS the image upgrade works.
It works also throughout whith every firmware version with the filezilla ftp-client,
but i need a C# ftp-client.

Now i change from 32 to a 64 bit machine and the problem happens again from time to time.
Maybe is this a reason?
asked Mar 1 in NET+OS by Josef New to the Community (3 points)
Can you please clarify your question? What steps exactly are you performing? What is failing?
I upload the image.bin with this code

            string fName = Application.StartupPath + "\\image.bin";
            var file = new FileInfo(fName);
            FtpWebRequest request = (FtpWebRequest)WebRequest.Create(string.Format("ftp://{0}/{1}", "192.168.61.199", "image.bin"));
            request.Method = WebRequestMethods.Ftp.UploadFile;
            request.Credentials = new NetworkCredential("root", this.digiPassword);
            request.UseBinary = true;
            request.KeepAlive = false;
            request.UsePassive = true;
            var fs = new FileStream(file.FullName, FileMode.Open);
            byte[] fileContents = new byte[fs.Length];
            fs.Read(fileContents, 0, Convert.ToInt32(fs.Length));
            fs.Close();
            request.ContentLength = fileContents.Length;
            System.IO.Stream requestStream = request.GetRequestStream();
            requestStream.Write(fileContents, 0, fileContents.Length);
            requestStream.Close();
            FtpWebResponse response = (FtpWebResponse)request.GetResponse();
            response.Close();
         // response.StatusDescription is "226 Transfer complete"


then sometime the connect me 9210 has died, i can't find the IP, the green LED is constantly green.

Please log in or register to answer this question.

1 Answer

0 votes
Do you manually reset the ME9210 after programming is complete? Programming only starts after FTP session is closed and it takes time so if you do not give it sufficient time it may reset before programming is complete.
If you can reproduce this on the module with JTAG, you can dump FLASH contents containing image.bin and binary compare with actual image.bin you are programming to see if they match
answered Mar 4 by LeonidM Veteran of the Digi Community (3,165 points)
I did 100 tests about days ago with JTAG module
(i have no compare the FLASH with Image.bin)
The Device was then frozen with this debug-output:


NET+OS Version 7.5.2.2
Copyright (c) 1997-2011, 2013 Digi International, Inc.

PLATFORM: connectme9210_esp 4M/8M [Feb 04 2019 16:38:30]
APPLICATION: (null) [Feb  4 2019 16:38:00]
-----------------------------------------------------------------------------
NETWORK INTERFACE PARAMETERS:
  IP address on LAN is 192.168.61.200
  LAN interface's subnet mask is 255.255.255.0
  IP address of default gateway to other networks is 192.168.61.200
  Primary DNS server address is 208.67.222.222
  Secondary DNS server address is 208.67.220.220
HARDWARE PARAMETERS:
  Serial channels will use a baud rate of 115200
  This board's serial number is N99999999
  This board's Ethernet MAC Address is 00:40:9D:43:35:96
  After board is reset, start-up code will wait 1 seconds
  Default duplex setting for Ethernet connection: default
-----------------------------------------------------------------------------
Press any key in 1 seconds to change these settings.


IAM:AUTO-CONFIGURED IPv6 FE80::240:9DFF:FE43:3596 on eth0:3
IAM:STATIC IPv4 192.168.61.200 on eth0
Network IP configured.
FTP server started.
IAM:AUTOIP IPv4 169.254.49.181 on eth0:0
Checksum passed, writing to flash...
Firmware updated, quit the session to restart.
Resetting the system in 2 seconds...
so after programming it does not reboot and you no longer see anything on the console. But you can recover device via tftp when shorting pins?
I would dump FLASH of that module and compare what is in FLAH with what should be there.
Are you programming just image.bin or also rom.bin?
With shorting pins, i can recover the device.

Now i have a new connect me 9210 with jtag,
with this i can not reproduce this FLASH error.

Only image.bin becomes programmed.
this is very strange that you can't reproduce it on the module with JTAG. Can you program both modules with exactly the same firmware (rom.bin and image.bin) and try again?
Do you experience it with just one module or all JTAGless modules?
...