Home/Support/Support Forum/RpPages.c incorrectly referencing Pgmesh in Connect ME build
Welcome to Digi Forum, where you can ask questions and receive answers from other members of the community.

RpPages.c incorrectly referencing Pgmesh in Connect ME build

0 votes
I am using Digi ESP for NET+OS (7.5.2). I have created and successfully built a project for the Digi Connect ME 9210 platform that I am trying to now use on a Connect ME module.

The build fails where web/result/fixed/RpPages.c incorrectly references Pgmesh that doesn't appear to be included in the bsp.

The build error results:

./web/result/fixed/RpPages.o:(.data+0x58): undefined reference to `Pgmesh_config'
./web/result/fixed/RpPages.o:(.data+0x5c): undefined reference to `Pgmesh_config_Form_1'
./web/result/fixed/RpPages.o:(.data+0x60): undefined reference to `Pgmesh_legacy_serial_config'
./web/result/fixed/RpPages.o:(.data+0x64): undefined reference to `Pgmesh_legacy_serial_config_Form_1'
./web/result/fixed/RpPages.o:(.data+0x68): undefined reference to `Pgmesh_zigbee_advanced_config'
./web/result/fixed/RpPages.o:(.data+0x6c): undefined reference to `Pgmesh_zigbee_advanced_config_Form_1'
./web/result/fixed/RpPages.o:(.data+0x70): undefined reference to `Pgmesh_zigbee_config'
./web/result/fixed/RpPages.o:(.data+0x74): undefined reference to `Pgmesh_zigbee_config_Form_1'
./web/result/fixed/RpPages.o:(.data+0x78): undefined reference to `Pgmesh_zigbee_config_table'
./web/result/fixed/RpPages.o:(.data+0x7c): undefined reference to `Pgmesh_zigbee_config_table_Form_1'
./web/result/fixed/RpPages.o:(.data+0x80): undefined reference to `Pgmesh_network_view'
./web/result/fixed/RpPages.o:(.data+0x84): undefined reference to `Pgmesh_network_view_Form_1'
./web/result/fixed/RpPages.o:(.data+0x88): undefined reference to `Pgmesh_device_state'
./web/result/fixed/RpPages.o:(.data+0x8c): undefined reference to `Pgmesh_device_state_Form_1'
./web/result/fixed/RpPages.o:(.data+0x90): undefined reference to `Pgmesh_fw_update'
./web/result/fixed/RpPages.o:(.data+0x94): undefined reference to `Pgmesh_fw_update_Form_1'
collect2: ld returned 1 exit status
make: *** [image.elf] Error 1
make: Target `all' not remade because of errors.

I have removed these 16 references from rpObjectDescriptionPtr gRpObjectList[] and I was wondering if this safe/acceptable to do? There are no longer any build errors and I hope that this will not adversely impact functionality.

Thank you for any insight/advice
asked Sep 11 in NET+OS by WMiller New to the Community (3 points)

Please log in or register to answer this question.

1 Answer

0 votes
 
Best answer
Did you install all the patches via package manager then created new project? Or are you trying to build existing project after installing patches?
If after installation a sample project fails to build, I suspect there is a problem with that installation. I would re-install, install all the patches, then create new project and try to build.
I doubt you are using Xbee, so it's ok to comment those out, but you should not have to do this.
answered Sep 12 by LeonidM Veteran of the Digi Community (3,126 points)
selected Oct 11 by WMiller
...